Want to stay on top? Ruby Weekly is a once-weekly e-mail newsletter covering the latest Ruby and Rails news.
     Feed Icon

Ruby 1.9.1 Release Candidate 1 Released

By Peter Cooper / December 30, 2008

Yuki Sonoda has just announced the release of Ruby 1.9.1 Release Candidate 1 on the ruby-talk mailing list:

This is a release candidate of Ruby 1.9.1, which will be the first stable version of Ruby 1.9 series. Try it early and have a experience of modern, faster, with clearer syntax, multilingualized and much improved Ruby world.

We have fixed 72 bugs and implemented some features. If you encounter a bug or a problem, please let us know it via the official issue tracking system.

If you're a Ruby developer, particularly if you have any libraries out in the field, getting up to speed with Ruby 1.9 is becoming a necessity. There are still bugs to be squashed (recently, for example, I found one in edge Rails on Ruby 1.9.1 beta - now fixed). Some libraries do not compile with Ruby 1.9 at all yet. Yet Ruby 1.9.1's performance and general stability are so encouraging that popular migration to Ruby 1.9 is certainly on the horizon.

When Ruby 1.9.1 finally drops and the Ruby 1.9 branch is considered production ready, we'll be doing a big round up of Ruby 1.9 news, links, and resources, but till then you might find Dr Nic's guide "Future proofing your Ruby code - Ruby 1.9.1 is coming" to be very useful. Sam Ruby's OSCON presentation on Ruby 1.9 should also prove illuminating if your expose to 1.9 has been minimal so far.

(Update: Ryan Grove has written How to compile and install Ruby 1.9.1 on Mac OS X Leopard - a handy guide to downloading and compiling Ruby 1.9.1 for yourself on OS X.)

Comments

  1. Sebastian says:

    A link to upgrading your version of Ruby to 1.9.x on OS X would be great -- I imagine a lot of folks out there don't want to mess up their current 1.8.x installation.

    But great news! :)

  2. John says:

    Great job the Ruby programmers have done!

    Now we need to get the Gems compatible... hpricot surprisingly still isn't compatible with Ruby 1.9. C'mon _why :)

  3. John says:

    @Sebastian: I don't know if this helps with Mac, but here is how I install Ruby 1.9 alongside Ruby 1.8 on Linux.

    ./configure --prefix=/usr --program-suffix=19
    make && sudo make install

    Then ruby19 and gem19 are your executables for Ruby 1.9, while "ruby" and "gem" still work as expected for Ruby 1.8.

  4. rebotnik says:

    Need the masses to move to 1.9 as soon as possible, the lack of gems that are compatible is very frustrating.

    1.9 is the future...

  5. Geoffrey Grosenbach says:

    @John #3: In my experience, gem executables installed by the gem19 command won't have the 19 suffix by default (for example if you upgrade rake). So installing with --prefix=/usr/local or a specific ruby19 subdirectory of that will work better.

  6. naquad says:

    are there any articles on differences between 1.8 and 1.9 to move to 1.9 fast?

Other Posts to Enjoy

Twitter Mentions