Ruby Weekly is a weekly newsletter covering the latest Ruby and Rails news.

RubyGems 1.0.0 Released

By Peter Cooper / December 20, 2007

Eric Hodel has just announced the release of RubyGems 1.0.0. As you probably already know, RubyGems is the de-facto package / library manager for Ruby applications and libraries, and almost every Ruby developer will have a version installed. There aren't many new features with this major version release, but lots of fixes, tweaks, and stability and usability enhancements. One key thing to note, however, is that require_gem is no longer supported, so if you have code that depends on that, you will have a little work to do before upgrading.

If you're on RubyGems 0.8.5 or later, then you can upgrade easily with: gem update --system .. for older versions or people with no RubyGems installation so far, follow the instructions in the announcement.

Congratulations are due to Eric and everyone else who's worked on RubyGems so far for producing what is, in my opinion, one of the most essential Ruby tools out there.

(Update: I have seen some reports of problems regarding upgrading on Leopard and Ubuntu - 64 bit. You might want to read the comments on this post first and/or do some non-production testing to clarify issues on your own kit.)


  1. Carl Mercier says:

    I had problems after updating RubyGems on Leopard. If anybody runs into the same problems, here's what I did to fix it:

  2. Nathan says:

    I was coming here to say that you shouldn't update rubygems on leopard. I did once and used time machine to get back to where I was.

    I don't like macports, so sorry. I like dtrace. Also, removing the built in ruby may break some applications that rely on it.

    I wish you the best, but for now I am sticking with what came with the system.

  3. Nathan says:

    A quick look on my system made me think you might be able to do:

    gem update --system --install-dir /Library/Ruby/Gems/1.8

    I havn't tried it (I need to check my backups first), but it should work.

  4. Kevin Ballard says:

    A simple `sudo gem update --system` worked fine on my Leopard system.

  5. Nick says:

    Here's my error output:

    sudo gem update --system
    Updating RubyGems...
    Attempting remote update of rubygems-update
    Successfully installed rubygems-update-1.0.0
    1 gem installed
    Updating version of RubyGems to 1.0.0
    Installing RubyGems 1.0.0
    ./lib/rubygems.rb:77: uninitialized constant Gem::RbConfig (NameError)
    from setup.rb:19

  6. Luis Lavena says:

    Peter, for the record I have added some comments in my last post about RubyGems and Rails 2.0.x:

    There is a small issue with gem_plugin (used by mongrel) and mongrel_service. All on Windows, so average *nix user won't be affected.


  7. Yen-Ju Chen says:

    Here is my solution:

    I use this solution to install Rails 2.0 with built-in Gem 0.8.5 on Leopard and everything works fine. Then I run the command 'sudo gem update --system' and it goes smooth. It shows '1.0.0' with 'gem -v'. After that, my Rails application still works and the installed gem seems fine. I haven't tried to install new gem with RubyGems 1.0 though.

  8. Dejan Dimic says:

    I am always thrilled when new RubyGems version arrived.
    My XP and Ubuntu are updated with no problems what so ever.

  9. John Joyce says:

    Make that 1.0.1 as of this morning, fixes issue with older versions of Ruby1.8
    Just installed it since I'm still running 1.8.4 on my OS X 10.4
    Takes a while to install, but no problem thus far.

  10. Laurent Sansonetti says:

    FYI, RubyGems supports Leopard since 0.9.5. You can therefore safely gem update --system and it will not break Leopard's Ruby configuration.

    The same goes for RubyGems 1.0.

  11. Joshua SIerles says:

    Be aware that Rubygems deprecates require_gem which is still in use in some older gems and may render them unusable.

Other Posts to Enjoy

Twitter Mentions